Clock problem - losing time, promise bios

3 replies [Last post]
Chriscb
Offline
Joined: Nov 16 2001

I have a Dell system running the following:
W98 2ed
PIII 700
512 ram
Promise Ultra 100 TX2 controller
1 x Maxtor 60g
2 x Barracuda iv 80g
DV Lite card
Pyro DV card - fw drive (80g)
Radaeon card.

Every thing worked very well until I updated the promise bios - then it all went wrong.

First I began to drop frames, so I defragged the 65G video partition, which took for ever.The pc clock lost 15 seconds for every minute real time.

Can't reinstall the old bios, despite making a back up as Promise suggest.

Any one any other idea's - could it be the new promise bios that's causing the problem?
Any one got the old bios they could e-mail to me?

As noted elsewhere in this forum, Promise have been very slow in responding to my email.

Thanks for you help.

Regards, Chriscb.

GG
Offline
Joined: Mar 16 2002

Hi Chris,

You didn't say exactly which model your Dell is, but.
Have you tried Dell's website
http://support.euro.dell.com/uk/en/home.asp

If you can find your model here they have downloads for everything including Bios.

Dell's can be a bit strange sometimes, it is possible you installed the wrong bios firmware if you didn't get the specific one for your model from Dell.
I had a similar problem with a Dell notebook.

rgds
GG

BSOD - a truly unique Microsoft innovation!

Chriscb
Offline
Joined: Nov 16 2001

Hi GG,

Thanks for the reply - but the BIOS problem is not with the Dell, but the Promise card.

For completeness, the Dell is a XPS T700R, and the bios is A11.

Regards,

Chriscb.

GG
Offline
Joined: Mar 16 2002

Opps!

Sorry should have read the question properly.

How about this one though.

Can you remove the promise card and plug an old HD straight into the onboard IDE. Run the PC for a while and check the Bios clock, etc. if you still have problems with the card removed. There might be other issues.

Maybe your PC's Bios settings have become corrupted during the Promise update.

If so try setting the CMOS reset jumper on the MB or remove the battery for a few minuets. Take a note of your settings first.

If everything seems ok though you can be sure that it is down to the card.

As I said before Dell's can be a bit strange. Have you got another PC you can put the card into to try going back a Bios version, or update the same version again. It may not have written correctly to the flash.

My job requires me to do firmware updates on all sorts of equipment, they often don't go exactly to plan.

I know that Bios updates on PC's especially of any sort can often end in tears.

Just a few ideas. Good luck.

GG

BSOD - a truly unique Microsoft innovation!