DMA with Promis 66, RT2000 and win98?

2 replies [Last post]
ChrisBitz
Offline
Joined: Jun 8 1999

Hi...

I've read that for the RT2000 to work well, you need to enable DMA in win98. I've looked ad HDD in Device manager, and the DMA checkbox doesn't even exist!
If I run the Matrox disk speed utility, it says DMA is not enabled....
The disk is a new Maxtor 40GB jobbie, and is certainly capable of 66 DMA whateveritis... :)

Any ideas?

Chris.

duncan hancox
Offline
Joined: Aug 15 2000

what is your motherboard? is it a bx based board?

the problem with dma is that the motherboard must recognise the disk as dma at the bios/interface level before windows can enable dma

newer dma66 disks (yours is) are not recognised by intel bx boards (and some others) as dma, since they only know about dma33. the dma66 disk is treated as an older PIO disk. as a result, windows doesnt enable dma at all.

the solution is to turn off the dma66 and make the disk report itself as dma33 - the motherboard can then recognise it and let windows enable dma

to do this, you must use a dos utiltity from your disk supplier and run it from a real-mode dos prompt.(re-start in ms-dos mode or boot from a floppy disk)

download the utility from your disk manufacturer web site

the other common problem with dma is that a dma66 capable motherboard is used with a dma66 disk , but with the wrong type of cable which only lets you use dma33.

however, if you are using a dma66 disk in dma33 mode on a bx board, you only need the older type of dma33 cable (dma66 cable should not cause any problems but isnt necessary)

ChrisBitz
Offline
Joined: Jun 8 1999

Superb reply!!

Thank you very much... It is a BX board!

Supermicro P6DBE

Thanks again...

Forever indebted... :) gush gush gush....

Chris.