HD Gloom again

1 reply [Last post]
Peter Stedman
Joined: Oct 30 2000

Some time ago my D drive - a 200g Maxtor - used for video storeage, suddenly anounced it wanted reformating. Most of the content I had saved elsewhere, but I did loose some in the reformating. No idea what had caused the problem. However the drive has worked fine for quite a while now with a big project on it (backed up elsewhere) - until today.

This morning the same thing has happened in that it needs to be reformatted. I note in the Windows drive description that the drive name no longer shows 200g (D) but now calls it Local Disc (D).

My questions are obvious I suppose. What causes the problem? Is there a cure? Is it a sign that it's on its way out? As external large capicity external drives as now so much cheaper, should I just get another of those? (I already have one).

Advice appreciated.

Dave R Smith
Joined: May 10 2005

Hi Peter,

Extract below from this thread:
Hi Les,

I had 250GB external for several years - it turned on/off and showed in explorer automatically no problem.
I had similar symptoms - dropping out from being shown in explorer, though still showing on system via control panel.
Sometimes a reboot or connecting to different firewire socket would cure it.. but seemed to get worse/more persistant lost connections.
I used a 'good' moment to copy all data to another drive.
I've since switched to using internal drives within ICYBOX caddies - lower cost and hopefully more reliable.
I am assuming your Lacie is outside g'tee period - didn't help me, but I tried switching firewire cables (both 4 wire and 6 wire).

I note your problem is an internal drive. Most problems posted here seem to be external drives, so I'm hoping my use of caddys/internal drives is more reliable than external drives.