Win98 8GB limit problem....

2 replies [Last post]
Joined: Sep 12 2005

Hello Folks...
Could somebody please suggest an answer to my problem?
My old Win98 machine dates from late 1998 so it should be able to handle >8 GB successfully, which it does - up to a point.
I got a 20 GB disk and copied the original 8 GB disk to a 10 GB partition, and installed Linux on the remaining 10 GB. So far, so good. Now that I have tried downloading big files I find a problem. My Computer - Properties says that I have 7.56 GB used, 2.67 GB free, but Windows will not write any more on the disk - it complains that the disk is full.
Is this likely to be a Win98 problem, a BIOS problem, or just something I might have done?
The BIOS string is 05/13/98 - i440BX - W977 - 2A69KG09c - 00 which I believe that someone in this group has already identified as a Gigabyte GA-686BX - thanks.
I have tried switching the BIOS settings between LBA, NORMAL, & AUTO, all to no avail. I ran Partition Magic, which suggested changing an extended partition to extendedx, again no good.
So, I will be incredibly grateful is anyone can suggest a fix.
Thanks - Mike

harlequin's picture
Joined: Aug 16 2000

windows 98 or windows 98se ?
fat or fat32 partition ?

with fat32 you should manage up to 8GB ( which was a bios limitation) or beyond by using the software that came with drives which added a 'software wedge' to make the system believe it was only an 8GB drive and translated the real disk dynamics.

maximum single file size under win98se and fat32 is 4GB

my bx motherboard ( with p3-1.4ghz powerleap processor ) has happily used 20GB partitions.

Gary MacKenzie ( an account only used for forum messages )

Thinkserver TS140 , 750ti Graphics card  & LG 27" uws led backlight , Edius 8

Humax Foxsat HD Pvr / Humax Fox T2 dvbt

Joined: Sep 12 2005

Thanks for the quick reply, but I am afraid that I have been wasting your time! After a couple of sessions with Scandisk and Partition Magic partition check I find that "My Computer" now agrees with PM that the used space is 9416.2 MB, free space 1079.3 MB - so it was caused by disk faults all the time. The fact that the apparent limit was 8GB made me think that I had some mysterious bug.
Thanks again - Mike