IRQ problem on W2K

1 reply [Last post]
BobbyNg
Offline
Joined: May 14 2001

I have installed the DV now AV on my machine running W2K. After the installation, I found the card is using IRQ 9 which shares with many devices (sound card, network card). I have tried to plug it into another slot (slot 2 and 3) and tried to force the IRQ selection in the BIOS settings, but it still comes out at IRQ 9.

I just want to know if there's any way to change the IRQ settings manually in W2K? (I think w/o device conflicts, W2K doesn't allows you to do it manually).

Thanks and Advance.

JVID
Offline
Joined: May 22 2001

I've had DV.now AV and Premier 6 for several weeks now, and noticed the same thing. At present, there are about a dozen things sharing IRQ9 on my system, including a modem and network card (plus the three FAST drivers), and, although I have other issues with the software, the IRQ sharing doesn't appear to have an effect on any of them. I can only offer a quote from a W2k book that I have:
"W2k handles IRQ sharing differently. It does support sharing on PCI machines, but only if no ISA card is sharing the same IRQ as another card. (If this is the case)...W2k switches to a "polling" mode, wherein the CPU regularly checks for and services I/O requests rather than waits for IRQ lines to be activated."
For what it's worth, I subscribe to the "if it ain't broke, don't fix it" philosophy, and have decided to leave well enough alone.

JR