USB Drive 64GB No option for Formatting as FAT 32 in Windows SOLVED

No replies
Joined: Aug 20 1999

I have a problem (Did have a problem wink)

My 64GB Kingston USB drive used to be recognised by my Humax box, now it doesn't sad

As posted in another message I decided to format the USB drive as NTFS to beat the 4GB limit of FAT32

Now I don't have an option in Windows to Format the USB drive as FAT32, only exFAT which the Humax doesn't recognise

I even dried in DOS

1. connect USB drive to system.
2. go to device manager and select USB from Disk drives option.
3. Right click it and choose policies tab and set optimize for performance option.
4. close every thing and open command prompt
5. use format command: format *usbdrivename* /FS:FAT32 /Q /X

and I'm told 64GB doesn't support FAT32, which I am sure it was formatted as before my NTFS experiment

Does anyone have a solution?


UPDATE Sorted by this  Windows GUI version of fat32format.

If you have any Forum Suggestions please post them here